WordPress Gutenberg 10.2 provoquant des erreurs fatales


Les éditeurs WordPress découvrent que Gutenberg 10.2 (sorti le 17 mars 2021) provoque des «erreurs fatales» en raison d’un problème d’incompatibilité avec WordPress. Un éditeur a suggéré que les mises à jour automatiques de Gutenberg effectuent une vérification de compatibilité et déclenchent un avertissement en cas d’incompatibilité.

WordPress Gutenberg

Gutenberg est un éditeur de site WordPress visuel qui représente un changement radical par rapport à la façon dont les sites Web ont été construits nativement au sein du noyau WordPress.

Il permet aux éditeurs de créer des sites à l’aide de l’interface utilisateur graphique de blocs. Par exemple, une page Web peut être visualisée sous forme de blocs représentant le haut de la page (en-tête), la zone de contenu, la barre latérale, etc.

Publicité

Continuer la lecture ci-dessous

Gutenberg n’est pas encore terminé, la pleine capacité d’édition du site est toujours en cours. Donc, naturellement, en tant que technologie pas encore mature, les bogues doivent être anticipés, sinon attendus.

Erreur fatale Gutenberg 10.2

Un membre du groupe Facebook WordPress avancé a lancé une discussion pour documenter une erreur fatale rencontrée lors de la mise à jour vers Gutenberg 10.2.

Le message indiquait que l’erreur fatale se manifestait dans la version 5.6 de WordPress. Il a également été noté qu’un message GitHub sur l’erreur indiquait que Gutenberg 10.2 n’est pas non plus compatible avec WP 5.5.

Chronologie des versions de WordPress et Gutenberg

WordPress 5.7 est sorti le 9 mars 2021.

L’éditeur du site Gutenberg 10.2 est sorti un peu plus d’une semaine plus tard, le 17 mars 2021.

Les éditeurs de sites Gutenberg qui ont mis à jour vers WordPress 5.7 puis mis à jour vers Gutenberg 10.2 ne devraient pas voir cette erreur.

Publicité

Continuer la lecture ci-dessous

Cependant, les éditeurs qui ont mis à jour vers Gutenberg 10.2 mais pas WordPress lui-même peuvent rencontrer l’erreur fatale.

L’erreur fatale est particulièrement susceptible de se produire pour les éditeurs qui configurent leurs installations Gutenberg pour se mettre à jour automatiquement (mise à jour automatique) mais ne sont pas configurés pour mettre à jour automatiquement WordPress lui-même.

Une erreur a été notée dans les forums de support officiels de Gutenberg WordPress, mais au moment de la rédaction de cet article, il n’y avait pas de suivi.

Le problème de la faille fatale a également été documenté sur la page officielle Gutenberg GitHub.

À partir du rapport GitHub:

«Après la mise à jour vers 10.2.0, j’ai reçu un e-mail concernant un problème technique avec le plugin:

Une erreur de type E_ERROR a été provoquée à la ligne 59 du fichier… J’ai pu désactiver le plugin via ftp. Maintenant, je ne veux pas l’activer tant que je ne sais pas que cela a été réglé.

Une autre personne a indiqué qu’elle avait remarqué la même chose et a posté une capture d’écran:

Erreur fatale WordPress GutenbergCapture d’écran de l’erreur fatale WordPress Gutenberg

L’utilisateur qui a publié la capture d’écran a suivi avec:

«J’utilisais WordPress 5.6. Après la mise à niveau vers la version 5.7, tout a commencé à fonctionner comme prévu. »

La personne qui a lancé le message original sur GitHub a affirmé que c’était également son problème.

Publicité

Continuer la lecture ci-dessous

«Merci de m’avoir informé de la version 5.7. Je n’avais pas mis à jour WP non plus, je peux maintenant réactiver Gutenberg. »

Gutenberg 10.2 incompatible avec les anciennes versions de WordPress

Un autre rapport de GitHub Gutenberg a souligné que Gutenberg 10.2 provoquait des erreurs fatales dans les anciennes versions de WordPress.

Un éditeur utilisant la version 5.5.3 de WordPress a également signalé une erreur fatale ayant provoqué un plantage.

La personne signalant le problème a confirmé qu’il était spécifique à Gutenberg 10.2, déclarant:

«J’ai désactivé le plugin Gutenberg 10.2.0. Lorsque j’ai essayé de réactiver le plugin, l’erreur fatale est revenue.

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

La personne a fait une observation utile et a suggéré que Gutenberg 10.2 ne devrait pas être autorisé à mettre à jour (ou à mettre à jour automatiquement) sur les versions de WordPress inférieures à WP 5.7.

«Il ne devrait pas être possible de mettre à jour automatiquement le plugin Gutenberg sur un ancien site WP. Comme le résultat semble créer une erreur fatale. Comme il peut y avoir de nombreux sites qui rencontreront ce problème. »

Publicité

Continuer la lecture ci-dessous

C’est une bonne solution au problème! Si une incompatibilité connue existe entre Gutenberg 10.2 et les anciennes versions de WordPress, il est logique que les mises à jour automatiques dans ces situations s’arrêtent et génèrent un avertissement d’incompatibilité.

Les utilisateurs de l’éditeur de site Gutenberg qui publient avec une version de WordPress antérieure à WP 5.7 peuvent considérer qu’il est prudent de mettre à jour vers la dernière version avant de mettre à jour vers Gutenberg 10.2.

Citations

GitHub:
Gutenberg 10.2.0 verrouillé a causé une erreur fatale # 29977

GitHub:
Erreur fatale dans le plugin Gutenberg 10.2.0 # 29972

Facebook: Groupe WordPress avancé (adhésion au groupe requise pour afficher)
Pour info, la dernière mise à jour 10.2 du plugin Gutenberg provoquera une erreur fatale

Partager:

Partager sur facebook
Partager sur twitter
Partager sur telegram
Partager sur reddit
Partager sur linkedin
Partager sur pinterest

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Articles Similaires