WordPress Vulnerability Update – Journal des moteurs de recherche

0
109


WordPress a annoncé une mise à jour qui corrige dix-sept bogues et sept vulnérabilités. WordPress met automatiquement à jour les sites vers WordPress 5.4.1.

Il est important de vérifier que votre installation WordPress est mise à jour à la version WordPress 5.4.1.

Vulnérabilités des scripts intersites

WordPress a mis à jour son logiciel afin de remédier à de multiples vulnérabilités du Cross-site scripting (XSS). Il en existe deux types, XSS et XSS authentifié.

Une vulnérabilité de type XSS (Cross-Site Scripting) permet à un attaquant d’injecter un script malveillant sur une page web vulnérable.

Un cross-site scripting authentifié (Authenticated XSS) est la même vulnérabilité ; seule celle-ci se produit lorsqu’un utilisateur est connecté. L’utilisateur peut être n’importe qui, d’un membre du site jusqu’au niveau administrateur.

Les vulnérabilités XSS peuvent être utilisées pour attaquer les visiteurs du site ainsi que pour modifier une page web WordPress. Ces types de vulnérabilités peuvent être utilisés comme la première vague d’attaques qui peut débloquer et ouvrir la voie à des attaques plus graves.

C’est pourquoi il est important de rester au courant des vulnérabilités XSS et de garder votre installation WordPress patchée à la toute dernière version.

La mise à jour du logiciel ne s’est pas limitée à la correction des vulnérabilités XSS. Il y avait aussi d’autres types de vulnérabilités.

Capture d'écran de l'annonce officielle de la mise à jour de sécurité de WordPressCapture d’écran de l’annonce de la mise à jour de sécurité de WordPress 5.4.1

Tous les sites ne sont pas automatiquement mis à jour

WordPress a annoncé que les installations de WordPress à partir de WordPress 3.7 ont été automatiquement mises à jour. Cela signifie que les installations WordPress inférieures à 3.7 n’ont pas été automatiquement mises à jour.

L’annonce officielle de WordPress implique que les versions inférieures à 3.7 restent vulnérables, puisque cette vulnérabilité affecte toutes les versions de WordPress inférieures à 5.4.
Il est prudent de mettre à jour toute installation WordPress ancienne à la toute dernière version afin d’éviter toute vulnérabilité antérieure de WordPress.

Selon l’annonce officielle de WordPress :

« Cette version de sécurité et de maintenance comporte 17 corrections de bogues en plus de 7 corrections de sécurité. Comme il s’agit d’une version de sécurité, il est recommandé de mettre à jour vos sites immédiatement ».

Corrections de bogues

Il y a eu 17 corrections de bogues dans cette version. Les bogues typiques qui ont été corrigés sont le téléchargement de fichiers média cassés affectant certains navigateurs et la correction de conflits avec certains plugins, parmi beaucoup d’autres bogues.

Lisez l’annonce officielle de WordPress ici :

WordPress 5.4.1

WordPress 5.4.1



tout savoir sur la crypto

LAISSER UN COMMENTAIRE

Please enter your comment!
Please enter your name here