Vulnérabilité du plugin WordPress Ultimate Member

0
63


Aujourd’hui, il a été annoncé que les «vulnérabilités critiques et graves» affectent un plugin de création de communauté WordPress appelé Ultimate Member a été corrigé. Cette vulnérabilité est facile à exploiter et donne à l’attaquant un accès de niveau administrateur, ce qui signifie qu’il peut faire ce qu’il veut sur le site.

Voici comment Wordfence décrit la gravité de cet exploit:

«Cette vulnérabilité est considérée comme très critique car elle permet aux utilisateurs non authentifiés à l’origine d’élever facilement leurs privilèges à ceux d’un administrateur. Une fois qu’un attaquant a un accès administratif à un site WordPress, il a effectivement repris l’intégralité du site et peut effectuer n’importe quelle action, de la mise hors ligne du site à l’infection du site avec des logiciels malveillants.

Plugin WordPress Ultimate Member

Le plugin Ultimate Member WordPress est une forme de plugin de création de communauté qui permet à un éditeur WordPress de permettre aux lecteurs de devenir des membres qui peuvent recevoir différents niveaux d’accès ainsi qu’interagir les uns avec les autres socialement.

Publicité

Continuer la lecture ci-dessous

C’est une solution qui peut également être utilisée pour restreindre l’accès au contenu aux utilisateurs enregistrés uniquement et pour accorder différents niveaux de privilèges d’adhésion, comme la publication sur le site.

Vulnérabilité ultime des membres

Il y a trois vecteurs exploitables dans le plugin et tous les trois sont des exploits d’escalade de privilèges. Un exploit d’escalade de privilèges se produit lorsqu’un attaquant peut augmenter ses privilèges d’utilisateur.

Par exemple, si quelqu’un est inscrit sur un site en tant qu’abonné, il peut faire des choses comme lire des articles et les commenter.

Mais avec un exploit, ils peuvent élever leurs privilèges de site du niveau d’abonné à un niveau d’administrateur et ainsi s’octroyer la possibilité de faire ce qu’ils veulent avec le site.

Un exploit d’escalade de privilèges authentifié se produit lorsqu’une personne a besoin d’une sorte d’authentification, comme un rôle d’abonné.

Publicité

Continuer la lecture ci-dessous

Avec un exploit d’escalade de privilèges non authentifiés, une personne n’a même pas besoin d’être un utilisateur enregistré.

L’exploit affecte le plugin Ultimate Member impliquait deux exploits non authentifiés et un exploit authentifié.

L’exploit Authenticated Privilege Escalation permet à un utilisateur enregistré de mettre à niveau ses privilèges.

L’exploit Escalade de privilèges non authentifiés permet à un attaquant d’utiliser le formulaire d’inscription comme vecteur d’attaque.

Ces exploits sont graves, jugés critiques et graves.

Voici comment WordFence le décrit:

«… Cette vulnérabilité est considérée comme critique car elle permet aux utilisateurs non authentifiés à l’origine d’élever leurs privilèges sous certaines conditions. Une fois qu’un attaquant a un accès élevé à un site WordPress, il peut potentiellement prendre le contrôle de l’intégralité du site et infecter davantage le site avec des logiciels malveillants. »

Mettre à jour immédiatement

Il est recommandé aux utilisateurs de mettre à jour immédiatement vers la version 2.1.12 du plugin Ultimate Member WordPress. Cette version contient le correctif qui corrige la vulnérabilité.

Citation

Les vulnérabilités d’escalade de privilèges critiques affectent 100 000 sites à l’aide du plugin Ultimate Member



tout savoir sur la crypto